Service Degradation - Flow Production Tracking
Incident Report for Flow Production Tracking
Postmortem

On October 11, 2024, between 06:50 AM PDT and 08:20 AM PDT, Autodesk experienced an incident that impacted customers using the Flow Production Tracking service.

Impacted Services

FPTR: Customers experienced latency issues and intermittent 503 errors.

Root Cause

A configuration change in the daily release created instability in the FPTR service. The release was rolled back to mitigate the issue.

Autodesk Actions

Autodesk has completed a post-incident analysis of the event and identified actions to be taken. These include the following:

  • Refining testing strategy to identify similar issues before they impact users
  • Improving monitoring systems and alert mechanism for a quicker response and mitigation

Thank you for your patience and understanding.

Posted Oct 18, 2024 - 15:57 UTC

Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 15:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 11, 2024 - 15:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 11, 2024 - 15:22 UTC
Investigating
We are observing a high number of failed requests to the Flow Production Tracking service which may impact site availability for some clients. Email notifications may also be delayed. This issue is under investigation.
Posted Oct 11, 2024 - 14:44 UTC
This incident affected: Flow Production Tracking and Notification Service.